Item Save Latency

Incident Report for Flyntlok Inc.

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 10:00 AKDT

Identified

We have identified that when saving or creating an item, the system does not provide a successful message. We are investigating the cause of this issue.
Posted Jul 03, 2025 - 07:12 AKDT
This incident affected: Flyntlok.